From: Tobias Schwinger (tschwinger_at_[hidden])
Date: 2007-06-19 06:20:08
Joel de Guzman wrote:
> Tobias Schwinger wrote:
>> I'm not too convinced that 'construct' gives a better name than
>> 'constructor', because looking at
>> I get the impression that something gets constructed, but in reality
>> it's just about capturing T's constructor in order to pass it around.
> So what? They're just lazy!
> I second Eric. "new_" and "construct" are better names.
> Subjective, nonetheless, but that's how it's spelled in Phoenix
> (ahem :) ahem). So, do I change all the names because phoenix
> functions are lazy?
Phoenix is lazy per-se, so imperative names are perfectly OK for that
For some general utility I'd prefer to emphasize the laziness. So what's
wrong with 'factory' in the first place?
Anyway, can those Phoenix tools be used as standard function objects
(with support for 'boost::result_of')?
If so, it's probably not worth the trouble writing something new...
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk