From: Alexander Nasonov (alnsn_at_[hidden])
Date: 2007-08-10 08:21:47
Kim Barrett <kab <at> irobot.com> writes:
> I wouldn't. When I said "backward compatibility variants" I meant
> macros with different names, with the "good" names used by the variadic
OK, I didn't realize that.
> So something like BOOST_SCOPE_EXIT_PPSEQ (with no preference
> intended for that specific naming convention).
Not sure that people will like it. The macro is already long so adding
a suffix to it would make it harder to type and read. Don't forget the library
also supports BOOST_SCOPE_EXIT_TRY, BOOST_SCOPE_EXIT_TPL and even
Have a nice vacation!
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk