Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2007-08-22 09:55:28

on Mon Aug 20 2007, Howard Hinnant <> wrote:

> Here is a link to a reference implementation and a FAQ for mutexes,
> locks and condition variables I am currently anticipating proposing
> for C++ standardization (or subsequent TR).

FWIW, I don't like the name "accept_ownership," in part because the
try_to_lock case can also be seen as accepting ownership. I'd
actually prefer "prelocked," even though it's not grammatically
congruent with "try_to_lock" and "defer_lock." I like "deferred," but
I don't know how to do the same thing for "try_to_lock." Maybe


I like those. More declarative.

Dave Abrahams
Boost Consulting
The Astoria Seminar ==>

Boost list run by bdawes at, gregod at, cpdaniel at, john at