Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2007-08-22 22:17:19

on Wed Aug 22 2007, Howard Hinnant <> wrote:

> Ok, this is my last post for approximately 24 hours (for unrelated,
> personal reasons). If I don't answer in a timely fashion for a day,
> please know that it is not because I'm ignoring you.
> I wanted to leave off with a few "PS" type comments:
> On Aug 22, 2007, at 2:59 PM, Zach Laine wrote:
>> Could the folks who object to the
>> current design spell it out for me a bit more explicitly -- what in
>> the design is dangerous/inconvenient enough to throw away one or more
>> of the 4 goals?
> I would like to see an answer to Zach's question too. I do not know
> what the major objection is with the "current proposal". I only know
> that people are suggesting alternatives.

1. I'm extremely wary of turning what is almost certainly a
   programming error into an exception (std::vector<T>::at
   notwithstanding), for reasons laid out in this thread:

2. I think the concept of unique_lock is too fuzzy. I know what
   unique_ptr (and auto_ptr, and shared_ptr, and scoped_ptr) mean.
   With unique_lock, I can't quite tell. This might ultimately end up
   being fixed by a naming change, but I think there's an underlying
   conceptual problem, or at the very least, a missing rationale.

Dave Abrahams
Boost Consulting
The Astoria Seminar ==>

Boost list run by bdawes at, gregod at, cpdaniel at, john at