Boost logo

Boost :

From: Ion Gaztañaga (igaztanaga_at_[hidden])
Date: 2007-08-23 09:13:50

Cory Nelson wrote:
> Hi Ion,
> Given that iterator_to turns a reference into an iterator, shouldn't
> this be to_iterator?

Well, iterator_to was chosen in the review as the most convenient name
since means "return an iterator to a value".

> Also with the clear/erase_and_dispose functions could there be a
> default disposer that calls delete?

Yes, I can provide one if that's considered useful. Something like this?


> Thanks!
> --
> Cory Nelson



Boost list run by bdawes at, gregod at, cpdaniel at, john at