From: Yanchenko Maxim (maximyanchenko_at_[hidden])
Date: 2007-08-23 12:37:37
I agree with Steven,
This syntax looks same as the new Boost.Parameter syntax, and this is good for the Boost as a whole.
23.08.07, 20:03, Steven Watanabe:
> I prefer BOOST_SCOPE_EXIT((cref c)(ref r)(val v))
> for two reasons.
> 1) It makes it clear that they are /not/ function
> 2) It's slightly easier to implement because you
> can use BOOST_PP_SEQ_FOR_EACH.
> In Christ,
> Steven Watanabe
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk