Boost logo

Boost :

From: John Nielsen (junx_dk_at_[hidden])
Date: 2007-10-01 06:35:02

Hi list,

I am having a problem compiling boost-1.34.1. Google appears to be as stomped as I am.

The configure phase goes OK using "./configure --prefix=/usr":

Detecting Python version... 2.5
Detecting Python root... /usr
Unicode/ICU support for Boost.Regex?... disabled.
Generating Boost.Build configuration in user-config.jam...
Generating Makefile...

And then this happens during "make install":

./tools/jam/src/bin.linuxx86/bjam --user-config=user-config.jam --prefix=/usr --exec-prefix=/usr --libdir=/usr/lib --includedir=/usr/include install
/bin/sh: line 1: 8586 Segmentation fault (core dumped) ./tools/jam/src/bin.linuxx86/bjam --user-config=user-config.jam --prefix=/usr --exec-prefix=/usr --libdir=/usr/lib --includedir=/usr/include install
Not all Boost libraries built properly.

Every time bjam is run, it seg faults:

root:~/boost_1_34_1/tools/jam/src/bin.linuxx86# ./bjam
Segmentation fault (core dumped)

I even tried downloading the standalone boost-jam-3.1.14, and built it, but it executes with exactly the same result.
While writing this mail I saw that boost-jam-3.1.15 was just released. It too dumps its core in exactly the same way.

What am I doing wrong? Any pointers would be greatly appreciated.

Best regards,

John Nielsen
Søg fra alle websider med yderst effektiv beskyttelse. Hent Windows Live Toolbar GRATIS i dag!

Boost list run by bdawes at, gregod at, cpdaniel at, john at