Date: 2007-10-04 06:32:05
Wouldn't it make sense to combine boost:exception and boost:system (at
least error_code and error_category stuff)?
I find the error_code concept not only useful for system errors.
> on Tue Oct 02 2007, "Emil Dotchevski"
> <emil-AT-revergestudios.com> wrote:
> >> > Is "exception" the best choice of name for this library?
> >> I think the functionality of this library may be too
> specific to be
> >> given such a general name. There are several other things
> one might
> >> want to do in a library called "exception," the only relationship
> >> being that C++ exceptions are involved.
> > Do you mean the name of the library or the name of the
> defined class
> > exception?
> I meant the library.
> Dave Abrahams
> Boost Consulting
> Unsubscribe & other changes:
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk