Boost logo

Boost :

From: Beman Dawes (bdawes_at_[hidden])
Date: 2007-10-23 09:01:45

At the Kona meeting two weeks ago, the C++ committee accepted most of
the Diagnostics changes proposed in N2415.


Most of Boost.System doesn't change since it already reflects N2415.

The committee did, however, change the name of the nested "posix"
namespace to "posix_error". For consistency, that means the "Linux"
namespace changes to "linux_error" and the "windows" namespace changes
to "window_error". As a consequence, the "linux_error" enum changes to

To minimize code breakage, I've added namespace aliases to error_code.hpp:

     namespace posix = posix_error;
# endif

     namespace Linux = linux_error;
# endif

     namespace windows = windows_error;
# endif

That was sufficient to prevent any code breakage in the Boost.System and
Boost.Filesystem test code, but any user code that actually mentions the
linux_errno enum (rather than its constants) will have to be changed.


Boost list run by bdawes at, gregod at, cpdaniel at, john at