Boost logo

Boost :

From: Howard Hinnant (hinnant_at_[hidden])
Date: 2007-11-14 14:02:49

On Nov 14, 2007, at 1:29 PM, Andrey Semashev wrote:

> Beman Dawes wrote:
>> I'm not totally enthralled by the condition_variable_any name. If
>> someone has a suggestion for a more meaningful name, now is a good
>> time
>> to speak up.
> I wonder why not making condition_variable a template with a mutex
> type
> in its template parameter. We could specialize it on the boost::mutex
> type to have the current optimized condition_variable implementation
> and
> leave it implemented as condition_variable_any for a general case.

The rationale for the current design (with different names) can be
found here:

There is a bullet that begins with:

> If the condition is templated on mutex type, ...


Boost list run by bdawes at, gregod at, cpdaniel at, john at