Boost logo

Boost :

From: Tobias Schwinger (tschwinger_at_[hidden])
Date: 2007-12-07 04:51:38


thanks for reviewing the Forward utility.

Stjepan Rajko wrote:
> On Dec 3, 2007 2:57 AM, John Torjo <john.groups_at_[hidden]> wrote:
>> * What is your evaluation of the design?
> Clear enough. I would find the gref metafunction useful factored out
> in a separate include file (with a more descriptive name than gref
> like... forwardable<T>::type?
> lvalue_reference_to_which_is_bindable<T>::type :) ?)

It sorta exists already, as 'gref' is basically a more primitive version
of 'call_traits<T>::param_type.

>> * What is your evaluation of the implementation?
> I agree with Dave on the EBO suggestion (and thanks for the
> compressed_pair lesson)

 From my personal feeling inheriting from 'forward<F>' might be too rare
of a use case to optimize for. However, with two reviewers asking for
it I'll probably end up drowning my possibly premature assumptions on
what the user will or will not do in a sea of genericity :-)...

>> * What is your evaluation of the documentation?
> Sufficient.
>> * What is your evaluation of the potential usefulness of the library?
> Very useful. Although, I seem to run into cases where I want to have
> a forwarding function (not function object), or a forwarding operator.
> But maybe I'm wrong in preferring an actual function...

Something like 'make_forward_adapter'?


Boost list run by bdawes at, gregod at, cpdaniel at, john at