From: dan marsden (danmarsden_at_[hidden])
Date: 2007-12-27 09:11:41
Giovanni Piero Deretta wrote:
> shunsuke wrote:
>> BTW, I'm tempted to rename Egg to Boost.Functor.
I'd suggest avoiding Functor as a name. Functor has specific meaning in the
functional programming community, which is not consistent with what Egg
>What about Boost.Functional (already taken?) or
>Boost.FunctionAdapters, or, my favourite,
>Boost.FunctionObjectsOnSteroid :). Or just keep Egg, is simple and
>there is precendent for non descriptive names in boost.
Personally I like the name Egg, it's short enough for a namespace
name, and easy to remember. Boost.FunctionObjectsOnSteroid does have
a certain something as well :)
Sent from Yahoo! Mail - a smarter inbox http://uk.mail.yahoo.com
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk