From: Philip Garofalo (philgarofalo_at_[hidden])
Date: 2008-01-05 00:15:32
Herve, Nice speaking with you again also and I hope your new year is off to
a great start. I do in fact like next_partial_permutation as a name much
better than next_r_permutation. It more closely echoes both the interface
and behavior of STL's partial_sort. I will give the GACAP proposal a closer
study. In general, I think there should no longer be any questions as to the
need for combinatorial algorithms in Boost.
On Dec 23, 2007 10:33 PM, Philip Garofalo <philgarofalo_at_[hidden]> wrote:
> Hello Ben and Herve, I'm not sure if you already know but there's a
> previous submission for combinations and permutations (mine) in the
> sequence_algo folder of the sandbox. In fact, Herve helped out! :-) I've
> been away from it for five years. Check out the discussion thread in the
> archives. Nevertheless, I like your implementation. It's interesting that
> you chose a sorting method similar to mine, instead of using a parallel
> index array.
> Phil Garofalo
> On Dec 23, 2007 7:38 PM, Ben Bear <benbearchen_at_[hidden]> wrote:
> > Sorry. I had lost too many times.
> > 2007/12/6, Hervé Brönnimann < hervebronnimann_at_[hidden]>:
> > > http://photon.poly.edu/~hbr/boost/combination.hpp
> > My test showed that a bug exists in prev_mapping(). The last sentence
> > of prev_mapping() should be "return false;", but not "return true;".
> > Date of the tested combination.hpp is 2007-12-6.
> > I'll put my test tonight. It mainly test the increment/decrement of
> > the sequences and the returned flags.
> > _______________________________________________
> > Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk