Boost logo

Boost :

From: David Rodríguez Ibeas (dibeas_at_[hidden])
Date: 2008-03-06 01:45:57

Too late for review, but as it is just a comment on class names, who

On Thu, Dec 27, 2007 at 5:19 PM, Tobias Schwinger <tschwinger_at_[hidden]>

> > Second I would like a name like factory_ptr or factory_pointer more than
> > only factory for the class. It shows more whats the problem domain of
> > the factory, and stands more in parallel to factory_value.
> I disagree - it's just confusing :-) as one might conclude the factory
> itself for being a smart pointer or being applicable only to pointers.
> A similar argumentation applies to "factory_value".
For John, who dislikes the naming scheme, and trying to avoid the first
problem (misleading _ptr at the end maybe confusing with smart pointer
names), maybe names could be changed according to what they do, not what
they return. I am thinking in 'heap_factory' (more simple, misleading if
anyone uses a non-heap allocator) or 'allocated_factory' for the pointer
returning class, and something alike for 'factory_value', maybe


Boost list run by bdawes at, gregod at, cpdaniel at, john at