Boost logo

Boost :

From: Paul A Bristow (pbristow_at_[hidden])
Date: 2008-03-14 08:09:50


>-----Original Message-----
>From: boost-bounces_at_[hidden]
>[mailto:boost-bounces_at_[hidden]] On Behalf Of Martin Bonner
>Sent: 14 March 2008 10:33
>To: boost_at_[hidden]
>Subject: Re: [boost] Proto review
>From: Eric Niebler
>> Steven Watanabe wrote:
>>> users_guide\expression_construction\tags_and_meta_functions.html
>>> tag::posit: I don't like this name. It confused me at first since
>>> posit is a complete word which means something totally different.
>>> positive would be better. IMO.
>> My (screwy?) logic is as follows: unary minus is called "negate"
>> because there is a std::negate function object that applies unary
>> minus. And what is the opposite of the verb "negate"? It's "posit".
>The New Collins Concise English Dictionary (1982) by my desk has:
>Negate: 1. to nullify; invalidate. 2. to contradict
>Posit: 1. to assume or put forward as fact or the factual basis for an
>argument. 2. to put in position.
>I don't really see how you can say that "to posit" is the opposite of
>"to negate".

A little googling shows that various people have already invented "posate" as the opposite of 'negate'
and this makes much more sense to me, even if it hasn't made it into the Oxford English Dictionary yet.

("posate" may mean something rude in italian too, but hey/cioa ;-)


Paul A Bristow
Prizet Farmhouse, Kendal, Cumbria UK LA8 8AB
+44 1539561830 & SMS, Mobile +44 7714 330204 & SMS

Boost list run by bdawes at, gregod at, cpdaniel at, john at