Boost logo

Boost :

From: Jens Seidel (jensseidel_at_[hidden])
Date: 2008-03-25 08:49:54


I tried to build the release branch on a Linux OpenSuse 10.2 with
g++ (GCC) 4.1.2 20061115 (prerelease) (SUSE Linux)
and it worked well. I also called "make check" and the tests were

What I now miss is a config.log file which saved the arguments to
./configure (as used by autotools) since I already forgot how I started
the build :-) I think I just tried
./configure --prefix=...; make; make install; make check

I compiled my own program which uses Boost.Logging v1 and Boost.Test
as well as boost::shared_ptr and got many compiler warnings in
Boost.Test headers. Many of these (unused arguments) could easily be fixed
but nothing happened since I reported some of these 5 months ago in ...

OK, but I also got a new error once I try to start my test:

Test setup error: child has exited; pid: 1001; uid: 20576; exit value: 0

The problem seems to be related to a std::system() call, which I do not
understand! Without it it works!

Here is my test code:

#include <cstdlib>
#include <boost/test/included/unit_test_framework.hpp>
using boost::unit_test::test_suite;

void Vektor3Test1() { }

test_suite* Vektor3_test_suite()
  test_suite *test = BOOST_TEST_SUITE("Vektor3 test suite");

  return test;

test_suite* init_unit_test_suite(int, char *[])
  // leads to "Test setup error: child has exited; pid: 1001; uid: 30540; exit value: 0"
  test_suite *test = BOOST_TEST_SUITE("Master test suite");
  return test;

Any idea?


Boost list run by bdawes at, gregod at, cpdaniel at, john at