Boost logo

Boost :

From: Maciej Sobczak (prog_at_[hidden])
Date: 2008-04-14 03:25:21


Is there an established naming convention for enum names in Boost?
I don't see anything truly consistent.

Consider this:

enum eGrays { eBlack, eDarkGray, eGray, eLightGray, eWhite };

Is this commonly accepted by the Boost community?
If not, what alternative naming for the above would you propose?


Maciej Sobczak * *

Boost list run by bdawes at, gregod at, cpdaniel at, john at