Boost logo

Boost :

From: Maciej Sobczak (prog_at_[hidden])
Date: 2008-04-14 06:02:42


Paul A Bristow wrote:

> I don't think Boost have even *banned* camel mode - just deprecated it.

Which for reviewers of new or candidate libraries is (should be)
effectively the same.

> So
> enum grays { gray_black, gray_dark, gray, gray_light...}
> or
> enum grays {black_gray, dark_gray, gray_gray, light_gray...}
> would both seem only a little longer and *much* easier to read?


> Or is it a stronger 'this is an enum' marker that you are trying to achieve?

The marker (eSomething) was used in the project together with CamelCase
for classes and functions. It worked very well as far as readability is
concerned, but after moving everything to lowercase_with_underscores the
enum names now look like eForeigners.

Thanks for your response.


Maciej Sobczak * *

Boost list run by bdawes at, gregod at, cpdaniel at, john at