Boost logo

Boost :

From: John Maddock (john_at_[hidden])
Date: 2008-04-29 06:15:45

Folks I'm looking for some good names for some functions I'm on the brink of
adding to Boost.Math (all in namespace boost::math::):

T nextafter(T val, T dir)

Returns the next representable floating point value to "val" in the
direction of "dir". This name is basically fixed, since it's the one that
C99 uses.

T next_greater(T val)

Returns the next representable value greater than "val".

T next_less(T val)

Returns the next representable value less than "val".

T edit_distance(T a, T b)

Returns the number of floating point representations between values a and b.

So the questions are: can you think of any better names, or are these OK?

And should edit_distance return a signed or absolute value?

Thanks in advance, John.

Boost list run by bdawes at, gregod at, cpdaniel at, john at