From: John Maddock (john_at_[hidden])
Date: 2008-04-30 08:16:03
Paul A Bristow wrote:
>> -----Original Message-----
>> From: boost-bounces_at_[hidden]
>> [mailto:boost-bounces_at_[hidden]] On Behalf Of Hervé Brönnimann
>> Sent: 30 April 2008 12:20
>> To: boost_at_[hidden]
>> Subject: Re: [boost] [Math/nextafter] A question of naming
>> floatdistance(lhs, rhs)?
> Would adding an underscore be nicer:
> FPT float_distance(FPT lhs, FPT rhs);
That's more to the Boost style of things.
> And to be clear, this (and the other next functions) *only* apply to
> floating-point types. (not integer, not decimal, not interval,
> or any other type)?
AS far as the current implementation is concerned it's strictly limited to
floating point values, represented in base 2.