Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2008-05-01 14:46:36

on Tue Apr 29 2008, Kevin Lynch <> wrote:

> Paul A Bristow wrote:
>>> T next_greater(T val)
>>> Returns the next representable value greater than "val".
>>> T next_less(T val)
>>> Returns the next representable value less than "val".
>> pred and succ have been used elsewhere. They are shorter.
> I disagree with Paul here: I prefer the longer, more descriptive names,
> especially in a general purpose library.

We do have next() and prior() (not abbreviations!) already, which have
meaning for iterators, integers, etc.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at