Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2008-05-28 01:51:29

I don't know if thread_group is supposed to stay around now that we have
movable threads, but if we're going to keep it I would like to propose a
few changes.

1. add_thread should take an auto_ptr<thread> (and eventually
   unique_ptr<thread>) so the signature indicates the ownership

2. remove_thread should be called release_thread. "Release" is at least
   not ambiguous about whether the thing is being destroyed.

Dave Abrahams
BoostPro Computing

Boost list run by bdawes at, gregod at, cpdaniel at, john at