Boost logo

Boost :

Subject: Re: [boost] boost.org Source-Code, Concepts & Idioms.
From: Steven Watanabe (watanabesj_at_[hidden])
Date: 2008-10-14 15:12:57


AMDG

Hartmut Kaiser wrote:
>> Can this be made to format macro expansions nicely?
>>
>
> What do you mean by that?
>

Since the point is to make the code more readable,
if we do any macro expansion for instance:

#define SOME_MACRO(...) \
  template<class T> \
  class C { \
    /*stuff*/ \
  };

SOME_MACRO(x, y, z)

We don't want this all to end up on one line.

In Christ,
Steven Watanabe


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk