Boost logo

Boost :

Subject: Re: [boost] [numeric_cast] request for boost::numeric_downcast
From: Thorsten Ottosen (thorsten.ottosen_at_[hidden])
Date: 2008-11-14 09:02:54

David Abrahams skrev:
> on Tue Nov 11 2008, Thorsten Ottosen <> wrote:
>>> Not to me. In what sense is this proposed cast "down?"
>> Well, as you say, its narrowing.
>> The naming applied to polymorphic_cast and polymorphic_downcast is not
>> perfect either, since both can be used to "casting down".
> That's like saying a knife is badly named because it can be used for
> "slicing carrots."

Do you disagree with my proposal that we should have some consistent way
  of naming a cast that does a debug check, but otherwise is unchecked?

I suggested


but perhaps


which reads nice, but the names are getting awfully long.


Boost list run by bdawes at, gregod at, cpdaniel at, john at