Boost logo

Boost :

Subject: Re: [boost] [review][constrained_value]ReviewofConstrainedValueLibrary begins today
From: Robert Kawulak (robert.kawulak_at_[hidden])
Date: 2008-12-06 07:28:19

> From: vicente.botet

> It would be great if the documentation state explicitly that
> change_lower_bound(v, -5);
> do not compiles for bounded_int.

I'll try to somehow make this more obvious in the docs.

> And why not find a better name for bounded_int.

Any suggestions?

> This is exaclty what I was locking for, but it was no evident
> to me your library provided it already
> I see now that this is really a well designed library.

Nice to hear this. ;-)

Best regards,

Boost list run by bdawes at, gregod at, cpdaniel at, john at