Boost logo

Boost :

Subject: Re: [boost] [Boost-users] [review][constrained_value] Review of ConstrainedValue Library begins today
From: Robert Kawulak (robert.kawulak_at_[hidden])
Date: 2008-12-07 12:44:33

> From: Neal Becker

> There is confusion over bounded vs. bounded_int. Maybe
> rename bounded_int to compile_time_bounded, or static_bounded.

I'm not against changing the name if something better than bounded_int is
proposed. However, compile_time_bounded is longish and may be interpreted as
checking the bounds at compile time, while static_bounded may suggest that some
static members are involved. What do others think?

Boost list run by bdawes at, gregod at, cpdaniel at, john at