Boost logo

Boost :

Subject: Re: [boost] [mpl] sequence_tag
From: Steven Watanabe (watanabesj_at_[hidden])
Date: 2009-01-14 00:00:43


Aleksey Gurtovoy wrote:
> On Tue, 13 Jan 2009 13:04:56 -0600, David Abrahams <dave_at_[hidden]>
> wrote:
>> on Tue Jan 13 2009, Eric Niebler <> wrote:
>>> Thoughts? FWIW, I'd prefer MPL to rename the nested tag typedef to
>>> "mpl_tag".
>> I've no objections. Aleksey?
> I'd actually to do both: allow SFINAE on sequence_tag and implement
> Eric's "first look for "mpl_tag" before falling back on "tag""
> suggestion through that.

In addition to sequence tag, what about
tag, plus_tag, minus_tag, etc?

In Christ,
Steven Watanabe

Boost list run by bdawes at, gregod at, cpdaniel at, john at