Boost logo

Boost :

Subject: Re: [boost] [format] please add operator String()
From: Alex MDC (alex.mdc_at_[hidden])
Date: 2009-02-05 18:07:09

> Therefore I suggest that we add
> operator string_type() const { return str(); }
> to the interface of basic_format<>.
> Any comments?

Sorry to dig this up, but I am +10 for this change.

I'm currently in the process of removing hundreds of old fixed buffer +
sprintf() style log messages from our code and this would make my life a
*lot* easier (not to mention more readable).

The previous discussion didn't go too far, but if there is general support
for this change is there any reason it could not be included?

Alex MDC

Boost list run by bdawes at, gregod at, cpdaniel at, john at