Boost logo

Boost :

Subject: Re: [boost] [filesystem] Version 3 request for comments
From: Walter Landry (wlandry_at_[hidden])
Date: 2009-02-08 05:12:13

Beman Dawes <bdawes_at_[hidden]> wrote:
> A prototype implementation of version 3 of Boost.Filesystem is available
> for comment.

This was also true in the old version, but one thing that bothers me
is that the filesystem library defines a number of types:
regular_file, directory_file, fifo_file, symlink_file, etc. Why does
it append "_file" to the end of all of the names? Why is it not just
regular_file, directory, fifo, symlink, etc.? The corresponding
identification functions are named is_directory and is_symlink, which
seems inconsistent.

Walter Landry

p.s. I noticed that you changed the names of "nlink" and "readlink" to
the more clear names "hard_link_count" and "read_symlink". This might
be needlessly confusing for those familiar with Unix, but even Ken
Thompson said that, if he had to do it over again, he would have
spelled "creat" with an "e" ;)

Boost list run by bdawes at, gregod at, cpdaniel at, john at