Subject: Re: [boost] Review Request: Introduction of boost::string namespace and string-conversion functions
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2009-02-12 08:11:23
[mailto:boost-bounces_at_[hidden]] On Behalf Of Gevorg Voskanyan
> "Stewart, Robert" <Robert.Stewart_at_[hidden]> wrote:
> > From: boost-bounces_at_[hidden]
> > [mailto:boost-bounces_at_[hidden]] On Behalf Of
> > Vladimir.Batov_at_[hidden]
> > > 4) int i_from_s = boost::string::to(s)(-1);
> > >
> > > The above is a non-throwing variation of #1 with the default value
> > > provided for failed conversion.
> > That would read better as:
> > int j(boost::string::to(s).or(-1));
> 'or' is a keyword.
Ah, yes. I'd forgotten that bit of the Standard of which I don't avail myself. Nevertheless, the idea is sound. Andrey Semashev suggested "with_default," though I think "or_default" might read better.
IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk