Subject: Re: [boost] Review Request: Introduction of boost::string namespace and string-conversion functions
From: Daniel Hulme (st_at_[hidden])
Date: 2009-02-12 13:43:31
On Wed, Feb 11, 2009 at 11:54:09PM +0300, Andrey Semashev wrote:
> Could we come up with another name for the namespace? The string
> namespace looks too general to me and may potentially clash with
> std::string if "using namespace boost; using namespace std;" is written
> in the users' code.
How about boost::text?
* A quick search suggests it is unused;
* It doesn't seem to clash with anything in std::
* To my mind it includes other text representations than std::string
(e.g. std::rope, std::vector<char>);
* It excludes other uses of std::string or std::vector<char>, for
example using vector<char> as a replacement for vector<bool>.
-- "He is strongly identified with rebels, you see, and very popular with rabbles. They will follow him and he will fight to the last drop of their blood." Chris Boucher, Blake's 7 D13 âBlakeâ http://surreal.istic.org/ It's a kind of threat, you see.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk