Subject: Re: [boost] boost::string namespace and string-conversion functions
From: Vladimir Batov (batov_at_[hidden])
Date: 2009-02-14 06:41:36
> ... In response you advise me to drop this practice because you like your
> naming better.
No, I never said and I never meant that. If it came across that way , I
apologize. I said, "it just too limiting
and will not work in the long run",
> How many people were using your aux::string? I don't think that as many as
> Boost users out there.
True. aux::string was limited to about two dozen people of various skill
levels. Seemed like a good enough indication to me. Point taken though.
> ... Other participants also suggested better names, like "parse" or
> "convert". The point is that this name alone brings you the understanding
> of what the function does. "from" does not.
Yes, 'convert' is well worth considering. It might work both ways as well.
string s = boost::string::convert(-1); // to string
int i = boost::string::convert(str); // from string
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk