Subject: Re: [boost] Formal Review Request: Boost.String.Convert
From: Andrey Semashev (andrey.semashev_at_[hidden])
Date: 2009-02-18 17:34:27
Christopher Jefferson wrote:
> On 18 Feb 2009, at 22:16, Andrey Semashev wrote:
>> But I will lose generic ostreamability for my class then. Sorry, I
>> just don't see any advantages for differently named functions.
> I find differently named functions important for readability and
> correctness, particularly in templated generic code.
> Wouldn't it be easy to add 'to' and 'from' functions as simple wrappers
> around 'convert', for those who want them?
Well, such wrappers may be added, if wanted. But I don't think it should
be the main interface of the library. Such wrappers would have a more
narrow range of use cases, presumably, "to-string" and "from-string"
conversions. For other kinds of conversions the terms "to" and "from"
are really meaningless.