Subject: Re: [boost] Formal Review Request: Boost.Convert
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2009-02-23 11:15:55
On Thursday, February 19, 2009 5:05 PM
> Robert suggested renaming 'convert' to 'conversion' but I am
> not warming
> up to that (yet, you might have noticed I am slow) as I
> essentially see
> 'convert' as a functor, i.e. encapsulating as an action, i.e.
> a verb is
> more appropriate. For that reason the code itself looks
> readable (to me)
> as "boost::convert<int, string>" reads as 'convert int to string".
I assume that's a reference to me. My suggestion of "conversion" was as a namespace name. Were you referring to my suggestion of using "converter" for the function object and "convert" for the function template that would deduce template parameters?
Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP http://www.sig.com
IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk