Boost logo

Boost :

Subject: Re: [boost] Formal Review: Boost.RangeEx
From: Thorsten Ottosen (thorsten.ottosen_at_[hidden])
Date: 2009-02-25 12:46:47

Neil Groves skrev:
> Dear Giovanni,

>>> I do provide both alternatives, for example
>>> boost::make_uniqued_range(rng) is equivalent to rng | uniqued
>> IMHO the make_... syntax for range adaptors is horrible (i don't even
>> like the past tense, why not just unique?).
>> But why use two different names in the first place? Why not make
> I simply dislike lots of overloading particularly where the semantics are
> different. Perhaps the semantics aren't that different.

There are very different. The past tense is used for adaptors that
has O(1) complexity and merely wraps the range's iterators in a new type
of iterators.

An algorithm like


really modifies the range, | boost::adaptors::uniqued, does not.


Boost list run by bdawes at, gregod at, cpdaniel at, john at