Boost logo

Boost :

Subject: Re: [boost] [1.39.0] Beta candidate
From: Eric Niebler (eric_at_[hidden])
Date: 2009-04-27 12:25:50

Vladimir Prus wrote:
> Eric Niebler wrote:
>> I still have the same problem as before on cygwin. I run ./
>> and then ./bjam --help and get this:
>> Boost.Build V2 (Milestone 12)
>> Boost.Jam 03.1.17
>> ... and then bjam just hangs with the cpu pegged at 100%. I tried
>> ash.exe and rebaseall like someone suggested, but it hasn't helped. Can
>> anybody else reproduce this?
> For how long is this happening? Can you attach to bjam with a debugger,
> and get a stacktrace?

I've never had any gdb-foo to speak of, and certainly not on cygwin. If
I break in to bjam.exe from gdb (Ctrl-C, right?), I see this:

(gdb) info threads
* 6 thread 635300.0x9b304 0x762f6e39 in PulseEvent ()
    from /cygdrive/c/Windows/system32/kernel32.dll
   5 thread 635300.0x9b1e4 0x76fa9a94 in ntdll!LdrAccessResource ()
    from /cygdrive/c/Windows/system32/ntdll.dll
   4 thread 635300.0x9b1dc 0x76fa9a94 in ntdll!LdrAccessResource ()
    from /cygdrive/c/Windows/system32/ntdll.dll
   3 thread 635300.0x9b1c4 0x76fa9a94 in ntdll!LdrAccessResource ()
    from /cygdrive/c/Windows/system32/ntdll.dll
   1 thread 635300.0x9b1a8 0x00404a3b in ?? ()
(gdb) tb
No default breakpoint address now.
(gdb) bt
#0 0x762f6e39 in PulseEvent () from
#1 0x61004416 in _cygtls::call2 () from /usr/bin/cygwin1.dll
#2 0x00000000 in ?? ()
(gdb) thread 1
[Switching to thread 1 (thread 635300.0x9b1a8)]#0 0x00404a3b in ?? ()
(gdb) bt
#0 0x00404a3b in ?? ()
#1 0x00000000 in ?? ()

Not much there, is there? Is there anything specific you'd like me to try?

Eric Niebler
BoostPro Computing

Boost list run by bdawes at, gregod at, cpdaniel at, john at