Boost logo

Boost :

Subject: Re: [boost] AlRangeExandrescu?
From: Mathias Gaunard (mathias.gaunard_at_[hidden])
Date: 2009-07-29 07:28:50


Mathias Gaunard wrote:

> The only fundamental thing that would change behavior is boost::end,
> since it could potentially return a different type, but it being
> convertible should be enough not to break compatibility.

Actually no, my bad, it doesn't work.

template<typename Iterator>
void do_something(Iterator begin, Iterator end);

do_something(begin(range), end(range));

would fail.

boost::end must remain conservative, while boost::real_end (for lack of
a better name) can return a different type.


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk