Boost logo

Boost :

Subject: Re: [boost] [1.40.0] Beta 1 release candidate available
From: Francesco Guerrieri (f.guerrieri_at_[hidden])
Date: 2009-08-12 11:13:12

On Wed, Aug 12, 2009 at 9:52 AM, Vladimir Prus
<vladimir_at_[hidden]> wrote:
> Beman Dawes wrote:
> > 1.40.0 beta 1 release candidates are available at
> >
> > Before pushing the beta out to SourceForge, I'd appreciate it if
> > several people would try the release candidate and report success or
> > problems.
> FWIW, I have tried on Linux, with both stage and install, and with
> both --layout=system, and --layout=versioned, and things worked
> OK.
> --build-type=complete does not work with ICU installed in the
> same way as reported by Václav Haisman.
> It would be important to have somebody to test on Windows,
> using the "bootstrap.bat + .\bjam" procedure. I can do this,
> but not sooner than Saturday.

Hi, this is my first post to the ml, so I picked up a relatively easy task :-)
I have built the boost-windows-2009-08-11 rc without any glaring
errors, with visual studio 2010 beta1.

I simply did, from a visual studio 2010 prompt,

bjam.exe --toolset=msvc-10.0 --build-type=complete >build_complete.log 2>&1

The resulting project -config.jam was very simple, just one line with

using msvc ;

The last line of the log are the following:
...failed updating 6 targets...
...skipped 22 targets...
...updated 2199 targets...

I don't have time at the moment to run some regression tests. I began
following the procedure indicated on the docs but I found some minor
typos which slowed me, and now I'm late. It seems to me that, without
any tuning, there is some slightly misplaced path (for instance, this
is the output that I am getting
boost_root: C:/libs/boost-windows-2009-08-11
locate_root: C:/libs/boost-windows-2009-08-11

**** exception(205): std::runtime_error:
boost::filesystem::basic_directory_iterator constructor: The system
cannot find the path specified:
******** errors detected; see standard output for details ********

And this is only natural, since vin.v2\libs\regex doesn't contain any
test folder, while on the contrary .

Am I doing something wrong?

If needed I can attach the build log. Hope to have been of some help.

ps: the two small typos in the docs are the following:
1) in the Generating library status page
the path to library_test.bat is
..\..\..\tools\regression\src\library_test and not
2) another small glitch is that the Jamroot.jam didn't build the
library_status.exe. I added a #~ just before "explicit
library_status;" and it built, but contrarily to status.html
indications both process_jam_log.exe and library_status.exe were to be
found in a subdir of the bin\ folder (in my case they were to be found

Boost list run by bdawes at, gregod at, cpdaniel at, john at