Boost logo

Boost :

Subject: Re: [boost] [move][container] Review Request (new versions of Boost.Move and Boost.Container in sandbox and vault)
From: Ion Gaztañaga (igaztanaga_at_[hidden])
Date: 2009-08-24 03:25:54

Thomas Klimpel escribió:
> So my position is that the user better be prepared to expect that "a
> =
boost::move(b); " can be implemented as "a.swap(b)", because move
assignment is about efficiency, and a.swap(b) is often the most
efficient implementation of move assignment.

Some additional discussion can be found in this thread:

I was also against clear(), but somehow people convinced me and I added
clear() to my classes ;-)



Boost list run by bdawes at, gregod at, cpdaniel at, john at