Boost logo

Boost :

Subject: Re: [boost] [system][filesystem v3] Question about error_code arguments
From: Scott McMurray ([hidden])
Date: 2009-10-20 14:45:50

2009/10/20 Beman Dawes <bdawes_at_[hidden]>:
> Regardless, I'd like to hear Boosters views on the two interfaces
> above. Which do you prefer? Why?

Could it be spelt like this instead?

    void f(optional<error_code&> ec = {});

So it'd act like a pointer inside the function, but for users it'd
look like passing a normal reference?

Boost list run by bdawes at, gregod at, cpdaniel at, john at