Subject: Re: [boost] [rdb] 0.2.02
From: Darren Garvey (darren.garvey_at_[hidden])
Date: 2009-11-25 14:54:27
2009/11/25 Michael Caisse <boost_at_[hidden]>
> Jean-Louis Leroy wrote:
I have uploaded a new release to the vault. It contains :
This looked interesting last time I checked. Do you have a direct link?
> I use float_ (note: underscore) for the variable type for receiving float
>> values (and the length/null indicator). I am a bit tempted to switch to a
>> convention that would prevent clashes with C++ names, e.g. Float or FLOAT.
>> This would solve the problem of `select` clashing with the socket function
>> from the C lib, e.g. : SELECT(p.id, p.name).FROM(p) ...
> There is some precedent with this type of naming in phoenix and spirit. I
> have gotten
> used to the underscore convention and personally like it. I'm not a fan of
> capitalization scheme though I suspect it might find more appeal to those
> do more DB work than I.
+1 for using float_. The precendent for this is quite firmly set, I think.
I don't like the uppercase SELECT, etc. though. While it does mimic SQL, it
makes it looks like a macro. The Boost style guide recommends against using
uppercase letters in names.