Boost logo

Boost :

Subject: Re: [boost] [unordered] unordered_set::erase() complexity bug?
From: Daniel James (daniel_james_at_[hidden])
Date: 2009-11-30 02:52:44

2009/11/30 OvermindDL1 <overminddl1_at_[hidden]>:
> As another post showed there is precedent.

The precedents were operators where a different name could not be used.

>  I find the no_return
> cleaner to read personally, and I would not be abject to having it as
> a template parameter either as a policy (m.erase<no_return>(it))
> either, just seems and reads cleaner to me.

This is meant to be a short lived workaround, we shouldn't
over-engineer it. A new type and a template method is pretty
gratuitous. I prefer the simplest, least disruptive solution - adding
a new method with a different name. In the future when the method is
removed (it'll go through a deprecation process first) the resulting
error messages will be simpler and the name of the function will be
easily searched (both in code and for an explanation on the web).


Boost list run by bdawes at, gregod at, cpdaniel at, john at