Boost logo

Boost :

Subject: Re: [boost] [explore] Library Proposal: Container Streaming
From: Johan Nilsson (r.johan.nilsson_at_[hidden])
Date: 2009-12-01 05:25:53

Jeffrey Faust wrote:
> Jeffrey Bosboom wrote:
>> I've written simple versions of streaming operators (both output and
>> input) for the standard containers as a simple, low-barrier-to-entry
>> form of serialization. Do you plan to provide the input operators
>> too? (I understand this would involve some restrictions on the
>> streamed forms of the container elements to prevent parsing


>> By the way, "Explore" is a very uninformative name.
> I agree. It came about during BoostCon 2007 when we had some grander
> ideas about what this library would be. It was to be a way to
> 'explore'
> your data, and there were some initial template metaprogramming
> approaches. The library is ended up in a much more modest form, but
> the name has remained.
> Any ideas for a better name? 'container_streaming' is a bit wordy,
> and
> even misleading due to the lack of input operators.

Boost.PrettyPrint, of which the container support is only a part?

(the name might sound a bit silly, but has precedence)

/ Johan

Boost list run by bdawes at, gregod at, cpdaniel at, john at