Boost logo

Boost :

Subject: Re: [boost] [explore] Library Proposal: Container Streaming
From: Patrick Horgan (phorgan1_at_[hidden])
Date: 2009-12-01 16:01:46

Jeffrey Faust wrote:
> Jeroen Habraken wrote:
>> This reminds me of the repr() function in Python,
>> Maybe
>> Boost.Represent would make sense as name for the project, as it shows
>> a representation of the data.
> That's a good idea. I like it more than 'explore'. Still, to me it
> sounds like such a big word for something so basic in use. Unless
> you are extending it, there's literally no interface to the library
> other than operator<<.
> So I was thinking some more about a better name. What do you think of
> Boost.Out?
What's wrong with Boost.Repr? Out doesn't seem to quite capture it.
When I use operator<< to put something into a string, which I might
later send out to the user, I don't think of it going out right then.
Depends on what the stream is. Repr captures what it does better, i.e.
you get a representation of what the data is.


Boost list run by bdawes at, gregod at, cpdaniel at, john at