Boost logo

Boost :

Subject: Re: [boost] [std_rdb] [rdb] 0.2.02
From: joel falcou (joel.falcou_at_[hidden])
Date: 2009-12-07 09:19:48

Stewart, Robert wrote:
> Jean-Louis Leroy wrote:
>> I use float_ (note: underscore) for the variable type for
>> receiving float values (and the length/null indicator). I am a
>> bit tempted to switch to a convention that would prevent
>> clashes with C++ names, e.g. Float or FLOAT. This would solve
>> the problem of `select` clashing with the socket function from
>> the C lib, e.g. : SELECT(, ...
> I'm troubled by something named so like a built-in type behaving differently (the length/null indicator). I know the names are in a namespace, but given a using directive, they won't be scope resolved.
> "FLOAT" is definitely out as it looks like a macro. "Float" is against Boost naming conventions. That would seem to leave only an affix to modify the type name. The affix should be short, too, for convenience. Here are a couple of ideas; some are too long:
> db_float
> rdb_float
> nullable_float
> optional_float
> "rdb_float" is troubling because it would appear in the "rdb" (perhaps "std::rdb") namespace, so "rdb" is duplicated.
what about float_ living in rdb : rdb::float_ ?

Joel Falcou - Assistant Professor
PARALL Team - LRI - Universite Paris Sud XI
Tel : (+33)1 69 15 66 35

Boost list run by bdawes at, gregod at, cpdaniel at, john at