Subject: Re: [boost] review request: addition to type_traits library of is_less_comparable<T, U> and others
From: John Maddock (john_at_[hidden])
Date: 2009-12-08 05:40:36
>> > If you really want to support the "don't care"
>> > case for a return type, use has_operator_less<T, dont_care> where
>> > "dont_care" is a special placeholder type that you define
>> > (could use a better name though?).
> I like the idea and the name, though perhaps "any" would work, too.
Doesn't that potentially get confused with boost::any ?
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk