Subject: Re: [boost] bcp update #2: namespace renaming
From: Daniel James (daniel_james_at_[hidden])
Date: 2010-01-02 06:12:03
2010/1/2 Andrey Semashev <andrey.semashev_at_[hidden]>:
> On 01/01/2010 03:30 PM, John Maddock wrote:
>>> There are a few places where another namespace is used. A quick search
>>> found boost_asio_handler_alloc_helpers, boost_concepts (in the
>>> iterator library), boost_optional_detail, boost_132 (in serialization)
>>> and boost_swap_impl. Will that be a problem?
>> Sigh... probably :-(
>> Is that a complete list of all the top level namespaces? If not, any
>> ideas on how to quickly produce one?
No. I just found those namespaces by searching for 'namespace boost_'
since most top level namespaces follow that pattern.
> I'm also aware of phoenix in Spirit v1.
Also BOOST_HASH_DETECT_FLOAT_FUNCTIONS in hash. I'm renaming it to be
lower case for consistency. It only contains function declarations, so
it might not create any symbols.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk