Subject: Re: [boost] [transaction] New Boost.Transaction library under discussion
Date: 2010-01-29 00:38:54
Zitat von "vicente.botet" <vicente.botet_at_[hidden]>:
>> any ideas for a namespace?
hmm, I assumed that was against some boost naming guideline, but I see
there are a number of libraries that use the plural (for no apparent
better. if we can come up with with something to the effect of
"transaction processing library" (but not "tpl") I'd prefer that but I
guess "transactions" is ok.
> Well, this do not concerns Boost.Transaction. From my side, I would
> let stm::transaction to refer to the single-phase transaction for STM.
ok, agreed. but just out of curiosity, what is your reasoning for doing that?
using boost.transactions should not have any overhead when used with a
single resource(no lazy transaction start either), so why do you want
to duplicate the code obtaining the active transaction etc. in your
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk