Boost logo

Boost :

Subject: Re: [boost] [transact] code in sandbox
From: strasser_at_[hidden]
Date: 2010-02-11 00:01:26

Zitat von "vicente.botet" <vicente.botet_at_[hidden]>:

>> *** new syntax for transaction scopes:
>> syntax changed from:
>> atomic{
>> ...
>> }retry;
>> to
>> do atomic{
>> }commit();
>> I prefer that syntax because it resembles the do{}while(...) syntax.
>> downside is that it conflicts with transaction::commit() if the user
>> chooses to define BOOST_TRANSACT_COMMIT to "commit" (as is done above).
> Maybe we can preserv both and see how the user react.

the user can easily create the old syntax using the existing macros:

#define atomic do BOOST_TRANSACT_ATOMIC

Boost list run by bdawes at, gregod at, cpdaniel at, john at