Subject: Re: [boost] [log] Comments
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2010-03-16 07:13:40
Steven Watanabe wrote:
> Andrey Semashev wrote:
> >> Of course I can use namespace aliases to alleviate the
> >> problem. However,
> >> I don't see how namespaces are necessary. Are there
> >> actually things with
> >> the same names in those different namespaces?
> > Yes. attr is a formatter and a filter, for example. There
> > are "format"
> > names in "formatters" and "keywords" namespaces. Perhaps
> > other exist, I didn't examine the code thoroughly.
> Is there a good reason that the same attr can't be both a
> formatter and a filter?
If not, it would probably make things more readable to have "attr_formatter" and "attr" anyway, though I'd prefer to see "attr" spelled out in each case.
Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP http://www.sig.com
IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk